June 2009 Hyper-V KB Articles

Microsoft has released a number of knowledge base articles for Hyper-V including some patches:

  • KB970089 A hotfix is available that addresses occasional crashes of Vmwp.exe processes on a Windows Server 2008-based Hyper-V host computer:  Fixes a crash problem that occasionally occurs on Windows Server 2008-based Hyper-V host computers. Specifically, some Vmwp.exe processes crash under stress conditions.
  • K2000048: Installing Service Pack 2 for Windows Server 2008 in a Hyper-V virtual machine may result in a Stop 0x7B if the beta version of the integration components were installed.  When you apply Service Pack 2 for Windows Server 2008 in a Hyper-V virtual machine, you may receive the following error message on startup after the service pack installation has completed and the virtual machine is restarted: Stop: 0x0000007B (0xFFFFFA60005B69C0, 0xFFFFFFFFC0000034, 0x0000000000000000, 0x0000000000000000).
  • KB957256: (Not open to non-Premier support subscribers yet) Description of methods to upgrade to Windows Server 2008 R2 from Windows Server 2008 with Hyper-V. This article describes methods that you can use to upgrade to Windows Server 2008 R2 from a Windows Server 2008 installation that has the Hyper-V role enabled.

That last article will probably go public soon.  However, for Hyper-V clusters it does redirect you to a public article: “For Windows Server 2008 clusters that are running virtual machines, visit the following Microsoft Web site for more information about migrating to Windows Server 2008 R2”.

Speaking of Hyper-V clusters, these updates were published in June for Windows 2008 clustering:

  • KB958807: Windows Server 2008 Failover Clustering WMI provider does not correctly handle invalid characters in the private property names causing WMI queries to fail.  Fixes an issue in which Windows Server 2008 Failover Clustering WMI provider does not properly handle invalid characters in the private property names causing WMI queries to fail.
  • KB967985: Error message on a Windows Server 2008-based computer when you run the High Availability wizard to add a new virtual machine to a Windows cluster:"That storage resource is already being used by another virtual machine".  Fixes an issue that an error message is returned on a Windows Server 2008-based computer when you run high availability wizard to add a new virtual machine to a Windows cluster. Provides a resolution to fix this issue.
  • KB967932: Terminal Session Broker Service does not start on a Windows Server 2008-based computer that is running Cluster Service.  Describes an issue in which the Terminal Session Broker service does not start on a Windows Server 2008-based computer that is running Cluster Service.

Finally, there are 3 Virtual Machine Manager (VMM) 2008 KB posts:

  • KB971816: Using P2V together with System Center Virtual Machine Manager 2008 may fail with error 3154 (0x8099319E).  When you perform a physical to virtual (P2V) conversion using System Center Virtual Machine Manager 2008, the P2V job may fail with the following error message: Error (3154) An internal error has occurred trying to contact an agent on the servername…
  • KB969269: SCVMM Admin Console crashes with error 1612 and Event ID 19999 and 1 are logged to the VM Manager event log.  The admin console crashes multiple times per day or perhaps the customer is unable to open the admin console. Sometimes the error displayed is 1612 (lost connectivity) or 1700 (during a refresh). These are only symptoms and not the underlying problem….
  • KB971244: Windows Remote Management (WinRM) does not accept HTTP authorization requests that are larger than 16 KB on a computer that is running Windows Server 2008 or Windows Vista.  Fixes an issue in which Windows Remote Management (WinRM) does not accept HTTP authorization requests that are larger than 16 KB on a computer that is running Windows Server 2008 or Windows Vista.

That should keep you busy 🙂  Make sure you test before you deploy anything into production.  And remember that MS usually recommends to only deploy updates that fix issues that you are having or could expect.

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.